summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:28:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:28:08 +0200
commit3f1dbe6b6de9d93deb82961353a970109e91db34 (patch)
tree9de2eb50f9078088bb0e31a542280ae4db5987ac /dev-ros/rqt_web/rqt_web-9999.ebuild
parentdev-ros/rqt_topic: Initial import. Ebuild by me. (diff)
downloadgentoo-3f1dbe6b6de9d93deb82961353a970109e91db34.tar.gz
gentoo-3f1dbe6b6de9d93deb82961353a970109e91db34.tar.bz2
gentoo-3f1dbe6b6de9d93deb82961353a970109e91db34.zip
dev-ros/rqt_web: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_web/rqt_web-9999.ebuild')
-rw-r--r--dev-ros/rqt_web/rqt_web-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_web/rqt_web-9999.ebuild b/dev-ros/rqt_web/rqt_web-9999.ebuild
new file mode 100644
index 000000000000..78b773c94243
--- /dev/null
+++ b/dev-ros/rqt_web/rqt_web-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple web content viewer for rqt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"