summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:54:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:54:13 +0200
commitf71ef21b97848acf2e5adca8f6179b4a876a2e29 (patch)
tree71175643a3b0b9d3867333d45fa502148c9331ca /dev-ros/rviz_python_tutorial/rviz_python_tutorial-9999.ebuild
parentdev-ros/rviz_plugin_tutorials: Initial import. Ebuild by me. (diff)
downloadgentoo-f71ef21b97848acf2e5adca8f6179b4a876a2e29.tar.gz
gentoo-f71ef21b97848acf2e5adca8f6179b4a876a2e29.tar.bz2
gentoo-f71ef21b97848acf2e5adca8f6179b4a876a2e29.zip
dev-ros/rviz_python_tutorial: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rviz_python_tutorial/rviz_python_tutorial-9999.ebuild')
-rw-r--r--dev-ros/rviz_python_tutorial/rviz_python_tutorial-9999.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/rviz_python_tutorial/rviz_python_tutorial-9999.ebuild b/dev-ros/rviz_python_tutorial/rviz_python_tutorial-9999.ebuild
new file mode 100644
index 000000000000..45523dbcd5c8
--- /dev/null
+++ b/dev-ros/rviz_python_tutorial/rviz_python_tutorial-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-visualization/visualization_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tutorials showing how to call into rviz internals from python scripts"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rviz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"