summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 19:01:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:25 +0200
commit3d9b7154a7857f8c96b28eb54af31986f73f3cd2 (patch)
tree596d9e8ca05c0eaad2086c0667b4c461188cafb6 /dev-ros/self_test/self_test-1.8.8.ebuild
parentdev-ros/diagnostic_common_diagnostics: Initial import. Ebuild by me. (diff)
downloadgentoo-3d9b7154a7857f8c96b28eb54af31986f73f3cd2.tar.gz
gentoo-3d9b7154a7857f8c96b28eb54af31986f73f3cd2.tar.bz2
gentoo-3d9b7154a7857f8c96b28eb54af31986f73f3cd2.zip
dev-ros/self_test: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/self_test/self_test-1.8.8.ebuild')
-rw-r--r--dev-ros/self_test/self_test-1.8.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/self_test/self_test-1.8.8.ebuild b/dev-ros/self_test/self_test-1.8.8.ebuild
new file mode 100644
index 000000000000..031f298dd431
--- /dev/null
+++ b/dev-ros/self_test/self_test-1.8.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot self-test node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs
+ dev-ros/diagnostic_updater
+ dev-ros/roscpp
+ dev-ros/rostest
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"