summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 14:02:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 14:33:25 +0200
commitb465d4623a8d4ed2c5fdcb8206edfdd3404fad17 (patch)
treefb583c036badc9a84c4e5daaeebd50ff4224acc2 /dev-ros/smach_ros/smach_ros-2.5.0.ebuild
parentdev-ros/smach: Bump to 2.5.0. (diff)
downloadgentoo-b465d4623a8d4ed2c5fdcb8206edfdd3404fad17.tar.gz
gentoo-b465d4623a8d4ed2c5fdcb8206edfdd3404fad17.tar.bz2
gentoo-b465d4623a8d4ed2c5fdcb8206edfdd3404fad17.zip
dev-ros/smach_ros: Bump to 2.5.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/smach_ros/smach_ros-2.5.0.ebuild')
-rw-r--r--dev-ros/smach_ros/smach_ros-2.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/smach_ros/smach_ros-2.5.0.ebuild b/dev-ros/smach_ros/smach_ros-2.5.0.ebuild
new file mode 100644
index 000000000000..08b54b8fcd47
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"