summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 21:26:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 21:30:01 +0200
commit4b6cd774c86538e5bf5cbd17418d5622c3548c45 (patch)
treed71dd54c49b314f579aaac983df6bb4be5782d75 /dev-ros/smach_ros/smach_ros-9999.ebuild
parentdev-ros/smach: Initial import. Ebuild by me. (diff)
downloadgentoo-4b6cd774c86538e5bf5cbd17418d5622c3548c45.tar.gz
gentoo-4b6cd774c86538e5bf5cbd17418d5622c3548c45.tar.bz2
gentoo-4b6cd774c86538e5bf5cbd17418d5622c3548c45.zip
dev-ros/smach_ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/smach_ros/smach_ros-9999.ebuild')
-rw-r--r--dev-ros/smach_ros/smach_ros-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/smach_ros/smach_ros-9999.ebuild b/dev-ros/smach_ros/smach_ros-9999.ebuild
new file mode 100644
index 000000000000..ec92913f50c1
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/smach[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"