summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-01 12:28:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-01 12:39:01 +0200
commit725c8511b81b77c2cf1b5dfc8cdeeceb87fc5721 (patch)
tree91ab1b22ef358a764085ced774648c8931125e6e /dev-ros/sound_play/sound_play-0.3.1.ebuild
parentdev-ros/audio_play: Bump to 0.3.1. (diff)
downloadgentoo-725c8511b81b77c2cf1b5dfc8cdeeceb87fc5721.tar.gz
gentoo-725c8511b81b77c2cf1b5dfc8cdeeceb87fc5721.tar.bz2
gentoo-725c8511b81b77c2cf1b5dfc8cdeeceb87fc5721.zip
dev-ros/sound_play: Bump to 0.3.1.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/sound_play/sound_play-0.3.1.ebuild')
-rw-r--r--dev-ros/sound_play/sound_play-0.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/sound_play/sound_play-0.3.1.ebuild b/dev-ros/sound_play/sound_play-0.3.1.ebuild
new file mode 100644
index 000000000000..c99812460fa2
--- /dev/null
+++ b/dev-ros/sound_play/sound_play-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS node that translates commands on a ROS topic (robotsound) into sounds"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib
+ media-libs/gstreamer:1.0
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ app-accessibility/festival
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-base:1.0
+"