summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-29 08:35:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-03-29 08:35:22 +0200
commitb20c78822d7f71b0695beb6e0457ae09a42d450f (patch)
tree4439fb26ba08a70b16521a637e375adf77a64062 /dev-ros/test_bond/test_bond-1.7.19.ebuild
parentdev-ros/smclib: Bump to 1.7.19. (diff)
downloadgentoo-b20c78822d7f71b0695beb6e0457ae09a42d450f.tar.gz
gentoo-b20c78822d7f71b0695beb6e0457ae09a42d450f.tar.bz2
gentoo-b20c78822d7f71b0695beb6e0457ae09a42d450f.zip
dev-ros/test_bond: Bump to 1.7.19.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/test_bond/test_bond-1.7.19.ebuild')
-rw-r--r--dev-ros/test_bond/test_bond-1.7.19.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/test_bond/test_bond-1.7.19.ebuild b/dev-ros/test_bond/test_bond-1.7.19.ebuild
new file mode 100644
index 000000000000..ba249ac5fc7b
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-1.7.19.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"