summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 12:54:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:22 +0200
commit94a2c702851b5ecf7a884547900cdb2001f9cfb5 (patch)
tree602b3e235bde2dbb78ff98b19261113a86f529aa /dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
parentdev-ros/self_test: Bump to 1.9.4. (diff)
downloadgentoo-94a2c702851b5ecf7a884547900cdb2001f9cfb5.tar.gz
gentoo-94a2c702851b5ecf7a884547900cdb2001f9cfb5.tar.bz2
gentoo-94a2c702851b5ecf7a884547900cdb2001f9cfb5.zip
dev-ros/test_diagnostic_aggregator: Bump to 1.9.4.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild')
-rw-r--r--dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
new file mode 100644
index 000000000000..6501cb2cc300
--- /dev/null
+++ b/dev-ros/test_diagnostic_aggregator/test_diagnostic_aggregator-1.9.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="diagnostic_aggregator tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_aggregator
+ dev-ros/diagnostic_msgs
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )