summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-17 12:17:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-17 13:46:32 +0200
commit56b834c5499a2f0197369e74c923d5182b7588f0 (patch)
tree81f00e9f27c521ebee9caa429d405bd5c38872dd /dev-ros/test_roscpp/test_roscpp-1.13.2.ebuild
parentdev-ros/test_rosbag_storage: Bump to 1.13.2. (diff)
downloadgentoo-56b834c5499a2f0197369e74c923d5182b7588f0.tar.gz
gentoo-56b834c5499a2f0197369e74c923d5182b7588f0.tar.bz2
gentoo-56b834c5499a2f0197369e74c923d5182b7588f0.zip
dev-ros/test_roscpp: Bump to 1.13.2.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-1.13.2.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.13.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-1.13.2.ebuild b/dev-ros/test_roscpp/test_roscpp-1.13.2.ebuild
new file mode 100644
index 000000000000..2aff5d7a157e
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.13.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"