summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-14 16:40:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-15 07:57:46 +0100
commit6a2a8a3554bc555b9ab3e136688c3a263b8ce472 (patch)
treeae218e6a2769139c1223d1945f0f79018792fc80 /dev-ros/test_roscpp/test_roscpp-1.13.5.ebuild
parentdev-ros/test_rosbag_storage: Bump to 1.13.5. (diff)
downloadgentoo-6a2a8a3554bc555b9ab3e136688c3a263b8ce472.tar.gz
gentoo-6a2a8a3554bc555b9ab3e136688c3a263b8ce472.tar.bz2
gentoo-6a2a8a3554bc555b9ab3e136688c3a263b8ce472.zip
dev-ros/test_roscpp: Bump to 1.13.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-1.13.5.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.13.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-1.13.5.ebuild b/dev-ros/test_roscpp/test_roscpp-1.13.5.ebuild
new file mode 100644
index 000000000000..2aff5d7a157e
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.13.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"