summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 18:28:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:02 +0200
commit72d0450d22b755b10aa6b8c6b743d0e9eab0734b (patch)
tree3becadfebc5f6b5f3e2cfdc59d799707b550c88d /dev-ros/test_roscpp/test_roscpp-1.15.7.ebuild
parentdev-ros/test_rosbag_storage: Bump to 1.15.7. (diff)
downloadgentoo-72d0450d22b755b10aa6b8c6b743d0e9eab0734b.tar.gz
gentoo-72d0450d22b755b10aa6b8c6b743d0e9eab0734b.tar.bz2
gentoo-72d0450d22b755b10aa6b8c6b743d0e9eab0734b.zip
dev-ros/test_roscpp: Bump to 1.15.7.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-1.15.7.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.7.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.7.ebuild
new file mode 100644
index 000000000000..e1720ee72889
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"