summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:12:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:51 +0200
commit92b123027489bcf74382f110371d4fce09350ae9 (patch)
tree8b6b3fe0559d634f364cb9b2fe508df25f62e749 /dev-ros/test_roslib_comm/test_roslib_comm-1.13.1.ebuild
parentdev-ros/test_roslaunch: Bump to 1.13.1. (diff)
downloadgentoo-92b123027489bcf74382f110371d4fce09350ae9.tar.gz
gentoo-92b123027489bcf74382f110371d4fce09350ae9.tar.bz2
gentoo-92b123027489bcf74382f110371d4fce09350ae9.zip
dev-ros/test_roslib_comm: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/test_roslib_comm/test_roslib_comm-1.13.1.ebuild')
-rw-r--r--dev-ros/test_roslib_comm/test_roslib_comm-1.13.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/test_roslib_comm/test_roslib_comm-1.13.1.ebuild b/dev-ros/test_roslib_comm/test_roslib_comm-1.13.1.ebuild
new file mode 100644
index 000000000000..cc727786c8e9
--- /dev/null
+++ b/dev-ros/test_roslib_comm/test_roslib_comm-1.13.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roslib"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] dev-ros/test_rosmaster )
+"