summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 10:00:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:53 +0100
commit6b84b5aafcc873a9563f1d4178909873fd23baee (patch)
tree35a84017872e26c86a2633b2fdd00bb55478c622 /dev-ros/test_rosmaster/test_rosmaster-1.13.0.ebuild
parentdev-ros/test_roslib_comm: Bump to 1.13.0. (diff)
downloadgentoo-6b84b5aafcc873a9563f1d4178909873fd23baee.tar.gz
gentoo-6b84b5aafcc873a9563f1d4178909873fd23baee.tar.bz2
gentoo-6b84b5aafcc873a9563f1d4178909873fd23baee.zip
dev-ros/test_rosmaster: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/test_rosmaster/test_rosmaster-1.13.0.ebuild')
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.13.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.13.0.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.13.0.ebuild
new file mode 100644
index 000000000000..3ffd2ba5e87f
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.13.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}