summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:33:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commitfc29ffa19eb5d422fb09e6957709838f84599c59 (patch)
tree8f74be665025fe51d2d301e96d9c2e6d2b18275b /dev-ros/test_rosparam/test_rosparam-1.11.15.ebuild
parentdev-ros/test_rosmaster: Bump to 1.11.15. (diff)
downloadgentoo-fc29ffa19eb5d422fb09e6957709838f84599c59.tar.gz
gentoo-fc29ffa19eb5d422fb09e6957709838f84599c59.tar.bz2
gentoo-fc29ffa19eb5d422fb09e6957709838f84599c59.zip
dev-ros/test_rosparam: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.11.15.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.11.15.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.11.15.ebuild b/dev-ros/test_rosparam/test_rosparam-1.11.15.ebuild
new file mode 100644
index 000000000000..7c14578e9162
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.11.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"