summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-14 16:40:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-15 07:57:47 +0100
commitb8e2a9ede5bf6ec03a9b592bb10846d01ca04344 (patch)
tree66f3d4ef6a0fa6c07de704a00dbb2eb3765c17ad /dev-ros/test_rosparam/test_rosparam-1.13.5.ebuild
parentdev-ros/test_rosmaster: Bump to 1.13.5. (diff)
downloadgentoo-b8e2a9ede5bf6ec03a9b592bb10846d01ca04344.tar.gz
gentoo-b8e2a9ede5bf6ec03a9b592bb10846d01ca04344.tar.bz2
gentoo-b8e2a9ede5bf6ec03a9b592bb10846d01ca04344.zip
dev-ros/test_rosparam: Bump to 1.13.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.13.5.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.13.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.13.5.ebuild b/dev-ros/test_rosparam/test_rosparam-1.13.5.ebuild
new file mode 100644
index 000000000000..5e1ce7075a30
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.13.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"