summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-09 11:01:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-09 12:39:10 +0100
commitb886914c32869d46a4b5ce83202b2ec7e6048252 (patch)
treecbe6009c3c1c151e05fcfd678ca67f2e3a71fd4b /dev-ros/test_rosparam/test_rosparam-1.13.6.ebuild
parentdev-ros/test_rosmaster: Bump to 1.13.6. (diff)
downloadgentoo-b886914c32869d46a4b5ce83202b2ec7e6048252.tar.gz
gentoo-b886914c32869d46a4b5ce83202b2ec7e6048252.tar.bz2
gentoo-b886914c32869d46a4b5ce83202b2ec7e6048252.zip
dev-ros/test_rosparam: Bump to 1.13.6.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.13.6.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.13.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.13.6.ebuild b/dev-ros/test_rosparam/test_rosparam-1.13.6.ebuild
new file mode 100644
index 000000000000..1c24d77d5702
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.13.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"