summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-14 12:05:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-14 12:05:59 +0100
commit12c9f4e90234e7da75019d3892d14f032d4cb28e (patch)
tree3a3f73edd5ccfd77628ed578dcce836e69f67e16 /dev-ros/test_rospy/test_rospy-1.11.16.ebuild
parentdev-ros/test_rosparam: Bump to 1.11.16. (diff)
downloadgentoo-12c9f4e90234e7da75019d3892d14f032d4cb28e.tar.gz
gentoo-12c9f4e90234e7da75019d3892d14f032d4cb28e.tar.bz2
gentoo-12c9f4e90234e7da75019d3892d14f032d4cb28e.zip
dev-ros/test_rospy: Bump to 1.11.16.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.11.16.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.11.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.11.16.ebuild b/dev-ros/test_rospy/test_rospy-1.11.16.ebuild
new file mode 100644
index 000000000000..174ea68dbec0
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.11.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"