summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:13:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:53 +0200
commitd7a2490b43c5ec959e393c3eb09bff3177de1b45 (patch)
treec9d16a608149c13c63b4784e2d0666e785b6d9dc /dev-ros/test_rospy/test_rospy-1.13.1.ebuild
parentdev-ros/test_rosparam: Bump to 1.13.1. (diff)
downloadgentoo-d7a2490b43c5ec959e393c3eb09bff3177de1b45.tar.gz
gentoo-d7a2490b43c5ec959e393c3eb09bff3177de1b45.tar.bz2
gentoo-d7a2490b43c5ec959e393c3eb09bff3177de1b45.zip
dev-ros/test_rospy: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.13.1.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.13.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.13.1.ebuild b/dev-ros/test_rospy/test_rospy-1.13.1.ebuild
new file mode 100644
index 000000000000..2c8306c903de
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"