summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-17 12:17:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-17 13:46:33 +0200
commit900cbe86299f4ec588ec3cc35b386943a875cabc (patch)
tree2eb9bbdd5eed0be6a291ea9e74fa02814c5dd625 /dev-ros/test_rospy/test_rospy-1.13.2.ebuild
parentdev-ros/test_rosparam: Bump to 1.13.2. (diff)
downloadgentoo-900cbe86299f4ec588ec3cc35b386943a875cabc.tar.gz
gentoo-900cbe86299f4ec588ec3cc35b386943a875cabc.tar.bz2
gentoo-900cbe86299f4ec588ec3cc35b386943a875cabc.zip
dev-ros/test_rospy: Bump to 1.13.2.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.13.2.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.13.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.13.2.ebuild b/dev-ros/test_rospy/test_rospy-1.13.2.ebuild
new file mode 100644
index 000000000000..2c8306c903de
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"