summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 11:32:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 12:05:44 +0100
commit7c2cc83efcf05853ea6476f8c254cb943ee03d77 (patch)
tree1f40ee14409b5199197235cde0140d20e7b6e0f5 /dev-ros/test_rospy/test_rospy-1.13.4.ebuild
parentdev-ros/test_rosparam: Bump to 1.13.4. (diff)
downloadgentoo-7c2cc83efcf05853ea6476f8c254cb943ee03d77.tar.gz
gentoo-7c2cc83efcf05853ea6476f8c254cb943ee03d77.tar.bz2
gentoo-7c2cc83efcf05853ea6476f8c254cb943ee03d77.zip
dev-ros/test_rospy: Bump to 1.13.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.13.4.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.13.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.13.4.ebuild b/dev-ros/test_rospy/test_rospy-1.13.4.ebuild
new file mode 100644
index 000000000000..2c8306c903de
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.13.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"