summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:57:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:44:00 +0200
commit740327cfc1e837aaad2e17d9ffbee9a3d0f43755 (patch)
treead9f89e8732b63afbbca17903ef9bc77fd927f21 /dev-ros/test_rospy/test_rospy-1.15.9.ebuild
parentdev-ros/test_rosparam: Bump to 1.15.9. (diff)
downloadgentoo-740327cfc1e837aaad2e17d9ffbee9a3d0f43755.tar.gz
gentoo-740327cfc1e837aaad2e17d9ffbee9a3d0f43755.tar.bz2
gentoo-740327cfc1e837aaad2e17d9ffbee9a3d0f43755.zip
dev-ros/test_rospy: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.15.9.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.15.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.15.9.ebuild b/dev-ros/test_rospy/test_rospy-1.15.9.ebuild
new file mode 100644
index 000000000000..5b429c7f5335
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.15.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ test? (
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/psutil[\${PYTHON_USEDEP}]")
+ )"