summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:26:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:56:46 +0100
commit9f1b21bd0ab90a2cf5ee6ce12648215bb139ddec (patch)
tree6e34cbdcf3b88810ef053b7dcf147b4770570687 /dev-ros/test_rosservice/test_rosservice-1.12.0.ebuild
parentdev-ros/test_rospy: Bump to 1.12.0. (diff)
downloadgentoo-9f1b21bd0ab90a2cf5ee6ce12648215bb139ddec.tar.gz
gentoo-9f1b21bd0ab90a2cf5ee6ce12648215bb139ddec.tar.bz2
gentoo-9f1b21bd0ab90a2cf5ee6ce12648215bb139ddec.zip
dev-ros/test_rosservice: Bump to 1.12.0.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.12.0.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.12.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.12.0.ebuild b/dev-ros/test_rosservice/test_rosservice-1.12.0.ebuild
new file mode 100644
index 000000000000..2a35b10b96ff
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"