summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-14 16:40:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-15 07:57:48 +0100
commit5144ac8ec5e51743261fe06a94310fad87fe5641 (patch)
tree8da0730d07756530007c5dc263029fe2bfbb50c6 /dev-ros/test_rosservice/test_rosservice-1.13.5.ebuild
parentdev-ros/test_rospy: Bump to 1.13.5. (diff)
downloadgentoo-5144ac8ec5e51743261fe06a94310fad87fe5641.tar.gz
gentoo-5144ac8ec5e51743261fe06a94310fad87fe5641.tar.bz2
gentoo-5144ac8ec5e51743261fe06a94310fad87fe5641.zip
dev-ros/test_rosservice: Bump to 1.13.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.13.5.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.13.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.13.5.ebuild b/dev-ros/test_rosservice/test_rosservice-1.13.5.ebuild
new file mode 100644
index 000000000000..36347c5c5286
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.13.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"