summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 13:51:53 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 15:46:56 +0100
commitfd80ab6610b491ad4d6d9cb16d14e0e580522681 (patch)
tree1a7f017ce3ae30f2096aab56c79ad927afb32429 /dev-ros/test_rosservice/test_rosservice-1.14.3-r1.ebuild
parentdev-ros/test_rosservice: Remove old (diff)
downloadgentoo-fd80ab6610b491ad4d6d9cb16d14e0e580522681.tar.gz
gentoo-fd80ab6610b491ad4d6d9cb16d14e0e580522681.tar.bz2
gentoo-fd80ab6610b491ad4d6d9cb16d14e0e580522681.zip
dev-ros/test_rosservice: upstream fix to yaml.load
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.14.3-r1.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.14.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.14.3-r1.ebuild b/dev-ros/test_rosservice/test_rosservice-1.14.3-r1.ebuild
new file mode 100644
index 000000000000..eb480554239e
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.14.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+PATCHES=( "${FILESDIR}/yaml.patch" )