summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:57:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:44:00 +0200
commit648fdd6423c222da4526c0f995277c8056c1d027 (patch)
treea800c3961af7526e581a3f15cec183a343cf3884 /dev-ros/test_rosservice/test_rosservice-1.15.9.ebuild
parentdev-ros/test_rospy: Bump to 1.15.9. (diff)
downloadgentoo-648fdd6423c222da4526c0f995277c8056c1d027.tar.gz
gentoo-648fdd6423c222da4526c0f995277c8056c1d027.tar.bz2
gentoo-648fdd6423c222da4526c0f995277c8056c1d027.zip
dev-ros/test_rosservice: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.15.9.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.15.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.15.9.ebuild b/dev-ros/test_rosservice/test_rosservice-1.15.9.ebuild
new file mode 100644
index 000000000000..7f51764ff341
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.15.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosservice[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"