summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-12 13:09:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-12 13:13:31 +0200
commit4e63bb86303e5bdc0a1068d77f3e9ba7cab116d3 (patch)
tree6ab66310b29ac0b54a213eb0f28822f1d9a3d91c /dev-ros/test_tf2/test_tf2-0.6.2.ebuild
parentdev-ros/tf2_tools: fix remoteid (diff)
downloadgentoo-4e63bb86303e5bdc0a1068d77f3e9ba7cab116d3.tar.gz
gentoo-4e63bb86303e5bdc0a1068d77f3e9ba7cab116d3.tar.bz2
gentoo-4e63bb86303e5bdc0a1068d77f3e9ba7cab116d3.zip
dev-ros/test_tf2: Bump to 0.6.2.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-0.6.2.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.6.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.6.2.ebuild b/dev-ros/test_tf2/test_tf2-0.6.2.ebuild
new file mode 100644
index 000000000000..9bfecde03150
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_msgs
+ sci-libs/orocos_kdl
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )