summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-16 12:44:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-16 14:17:01 +0200
commit6a12716efeaf16d8da04df4790c2fa963cae19b4 (patch)
tree6e2a61b5b25bae6a7ebe882310e69399037e4a36 /dev-ros/tf/tf-1.11.9.ebuild
parentdev-ros/kdl_conversions: Bump to 1.11.9. (diff)
downloadgentoo-6a12716efeaf16d8da04df4790c2fa963cae19b4.tar.gz
gentoo-6a12716efeaf16d8da04df4790c2fa963cae19b4.tar.bz2
gentoo-6a12716efeaf16d8da04df4790c2fa963cae19b4.zip
dev-ros/tf: Bump to 1.11.9.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ros/tf/tf-1.11.9.ebuild')
-rw-r--r--dev-ros/tf/tf-1.11.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/tf/tf-1.11.9.ebuild b/dev-ros/tf/tf-1.11.9.ebuild
new file mode 100644
index 000000000000..9fbd6e2ea2c0
--- /dev/null
+++ b/dev-ros/tf/tf-1.11.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between coordinate frames in a tree structure buffered in time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/angles
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"