summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-05 12:45:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-05 12:58:32 +0100
commitd3d3f86fa3688b5a6b5427e5268cd4684abdb1c4 (patch)
treef3bfb1901cd1684f4a6c2faab5d189d77134b515 /dev-ros/tf2/tf2-0.5.13.ebuild
parentdev-ros/test_tf2: Bump to 0.5.13. (diff)
downloadgentoo-d3d3f86fa3688b5a6b5427e5268cd4684abdb1c4.tar.gz
gentoo-d3d3f86fa3688b5a6b5427e5268cd4684abdb1c4.tar.bz2
gentoo-d3d3f86fa3688b5a6b5427e5268cd4684abdb1c4.zip
dev-ros/tf2: Bump to 0.5.13.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2/tf2-0.5.13.ebuild')
-rw-r--r--dev-ros/tf2/tf2-0.5.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/tf2/tf2-0.5.13.ebuild b/dev-ros/tf2/tf2-0.5.13.ebuild
new file mode 100644
index 000000000000..932df2ccb859
--- /dev/null
+++ b/dev-ros/tf2/tf2-0.5.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="The second generation Transform Library in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/console_bridge
+ dev-ros/rostime
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"