summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 12:02:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 12:45:56 +0200
commitf7fb23b2f9c577053b98d2f678b4188be84983ef (patch)
treeffbfeafdd7a10d9284810dc77307a1e51756d5cf /dev-ros/tf2/tf2-0.7.2.ebuild
parentdev-ros/test_tf2: Bump to 0.7.2. (diff)
downloadgentoo-f7fb23b2f9c577053b98d2f678b4188be84983ef.tar.gz
gentoo-f7fb23b2f9c577053b98d2f678b4188be84983ef.tar.bz2
gentoo-f7fb23b2f9c577053b98d2f678b4188be84983ef.zip
dev-ros/tf2: Bump to 0.7.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2/tf2-0.7.2.ebuild')
-rw-r--r--dev-ros/tf2/tf2-0.7.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2/tf2-0.7.2.ebuild b/dev-ros/tf2/tf2-0.7.2.ebuild
new file mode 100644
index 000000000000..18aca1320b91
--- /dev/null
+++ b/dev-ros/tf2/tf2-0.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="The second generation Transform Library in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/console_bridge:=
+ dev-ros/rostime
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roscpp )
+"