summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 08:56:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 08:56:51 +0200
commit66f2247a6175c009669ce422ff96fcfa9844048a (patch)
tree823e685358a690141d5acbc0d81bf2f1960c3ba0 /dev-ros/tf2_geometry_msgs/tf2_geometry_msgs-0.6.3.ebuild
parentdev-ros/tf2_eigen: Bump to 0.6.3. (diff)
downloadgentoo-66f2247a6175c009669ce422ff96fcfa9844048a.tar.gz
gentoo-66f2247a6175c009669ce422ff96fcfa9844048a.tar.bz2
gentoo-66f2247a6175c009669ce422ff96fcfa9844048a.zip
dev-ros/tf2_geometry_msgs: Bump to 0.6.3.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros/tf2_geometry_msgs/tf2_geometry_msgs-0.6.3.ebuild')
-rw-r--r--dev-ros/tf2_geometry_msgs/tf2_geometry_msgs-0.6.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2_geometry_msgs/tf2_geometry_msgs-0.6.3.ebuild b/dev-ros/tf2_geometry_msgs/tf2_geometry_msgs-0.6.3.ebuild
new file mode 100644
index 000000000000..6e110987c542
--- /dev/null
+++ b/dev-ros/tf2_geometry_msgs/tf2_geometry_msgs-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="The second generation Transform Library in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ sci-libs/orocos_kdl
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"