summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-15 18:26:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-16 14:17:00 +0200
commit1b8feee70370f2dd3e49c3d6cafcad47a2e9dbe4 (patch)
tree370bcae5f7be1b0955e139a02aedb05b61cb9127 /dev-ros/tf2_tools/tf2_tools-0.5.16.ebuild
parentdev-ros/tf2_sensor_msgs: Bump to 0.5.16. (diff)
downloadgentoo-1b8feee70370f2dd3e49c3d6cafcad47a2e9dbe4.tar.gz
gentoo-1b8feee70370f2dd3e49c3d6cafcad47a2e9dbe4.tar.bz2
gentoo-1b8feee70370f2dd3e49c3d6cafcad47a2e9dbe4.zip
dev-ros/tf2_tools: Bump to 0.5.16.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ros/tf2_tools/tf2_tools-0.5.16.ebuild')
-rw-r--r--dev-ros/tf2_tools/tf2_tools-0.5.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2_tools/tf2_tools-0.5.16.ebuild b/dev-ros/tf2_tools/tf2_tools-0.5.16.ebuild
new file mode 100644
index 000000000000..d40cc4b3342e
--- /dev/null
+++ b/dev-ros/tf2_tools/tf2_tools-0.5.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"