summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-12 13:10:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-12 13:13:34 +0200
commit4ee37757139e910f6f280ba96e4928ad1f3202f6 (patch)
tree6f640e5d086fd98cdbab24a23152540372dc9205 /dev-ros/tf2_tools/tf2_tools-0.6.2.ebuild
parentdev-ros/tf2_sensor_msgs: Bump to 0.6.2. (diff)
downloadgentoo-4ee37757139e910f6f280ba96e4928ad1f3202f6.tar.gz
gentoo-4ee37757139e910f6f280ba96e4928ad1f3202f6.tar.bz2
gentoo-4ee37757139e910f6f280ba96e4928ad1f3202f6.zip
dev-ros/tf2_tools: Bump to 0.6.2.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/tf2_tools/tf2_tools-0.6.2.ebuild')
-rw-r--r--dev-ros/tf2_tools/tf2_tools-0.6.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2_tools/tf2_tools-0.6.2.ebuild b/dev-ros/tf2_tools/tf2_tools-0.6.2.ebuild
new file mode 100644
index 000000000000..007bd064fc2d
--- /dev/null
+++ b/dev-ros/tf2_tools/tf2_tools-0.6.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"