summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:08:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:08:25 +0200
commit7245aa26d2c266edd566fbb8fb06163565b3d154 (patch)
tree5a4394beb3a4e0d089a147823c51c55898aafd90 /dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
parentdev-ros/compressed_image_transport: Initial import. Ebuild by me. (diff)
downloadgentoo-7245aa26d2c266edd566fbb8fb06163565b3d154.tar.gz
gentoo-7245aa26d2c266edd566fbb8fb06163565b3d154.tar.bz2
gentoo-7245aa26d2c266edd566fbb8fb06163565b3d154.zip
dev-ros/theora_image_transport: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/theora_image_transport/theora_image_transport-9999.ebuild')
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild b/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
new file mode 100644
index 000000000000..24e52f972f30
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ dev-ros/tf
+ media-libs/opencv
+ dev-ros/tf
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"