summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:11:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:49 +0200
commitdc473c0a8a536b694598bf6f2dce109cc5158770 (patch)
treeaa70085484c52d9c4b01d6368f7f9251dc77aa34 /dev-ros/topic_tools/topic_tools-1.13.1.ebuild
parentdev-ros/rostopic: Bump to 1.13.1. (diff)
downloadgentoo-dc473c0a8a536b694598bf6f2dce109cc5158770.tar.gz
gentoo-dc473c0a8a536b694598bf6f2dce109cc5158770.tar.bz2
gentoo-dc473c0a8a536b694598bf6f2dce109cc5158770.zip
dev-ros/topic_tools: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/topic_tools/topic_tools-1.13.1.ebuild')
-rw-r--r--dev-ros/topic_tools/topic_tools-1.13.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/topic_tools/topic_tools-1.13.1.ebuild b/dev-ros/topic_tools/topic_tools-1.13.1.ebuild
new file mode 100644
index 000000000000..22160468f6ca
--- /dev/null
+++ b/dev-ros/topic_tools/topic_tools-1.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"