summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-12 18:48:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-12 18:58:18 +0200
commite77397b92f654fb311183545e32abd3854722a0c (patch)
treea3ef6f2c95e6bf4c37c6663fb73f256a0d2784b5 /dev-ros/turtle_actionlib/turtle_actionlib-0.2.0-r1.ebuild
parentdev-ros/turtle_actionlib: Remove old (diff)
downloadgentoo-e77397b92f654fb311183545e32abd3854722a0c.tar.gz
gentoo-e77397b92f654fb311183545e32abd3854722a0c.tar.bz2
gentoo-e77397b92f654fb311183545e32abd3854722a0c.zip
dev-ros/turtle_actionlib: add slot dep on angles
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/turtle_actionlib/turtle_actionlib-0.2.0-r1.ebuild')
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-0.2.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-0.2.0-r1.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..21f40653b5e4
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-0.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles:0
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"