summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 14:17:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:21:12 +0200
commitb02ce9354fe234fab58d5280d7abe0325d21fbb4 (patch)
treed09ec4237187fe3a0fb24cafdf2c0ca32e3dff50 /dev-ros/turtle_actionlib/turtle_actionlib-0.2.0.ebuild
parentdev-ros/pluginlib_tutorials: Bump to 0.2.0. (diff)
downloadgentoo-b02ce9354fe234fab58d5280d7abe0325d21fbb4.tar.gz
gentoo-b02ce9354fe234fab58d5280d7abe0325d21fbb4.tar.bz2
gentoo-b02ce9354fe234fab58d5280d7abe0325d21fbb4.zip
dev-ros/turtle_actionlib: Bump to 0.2.0.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/turtle_actionlib/turtle_actionlib-0.2.0.ebuild')
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-0.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-0.2.0.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-0.2.0.ebuild
new file mode 100644
index 000000000000..f546db76e3fd
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"