summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:49:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:49:17 +0200
commita2f83eb52bd631c748ed8bdbdb341d82217fa953 (patch)
tree7a0077341ba05f2ab42abe2411286adf5cb25b81 /dev-ros/unique_id/unique_id-1.0.5.ebuild
parentdev-ros/uuid_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-a2f83eb52bd631c748ed8bdbdb341d82217fa953.tar.gz
gentoo-a2f83eb52bd631c748ed8bdbdb341d82217fa953.tar.bz2
gentoo-a2f83eb52bd631c748ed8bdbdb341d82217fa953.zip
dev-ros/unique_id: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/unique_id/unique_id-1.0.5.ebuild')
-rw-r--r--dev-ros/unique_id/unique_id-1.0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/unique_id/unique_id-1.0.5.ebuild b/dev-ros/unique_id/unique_id-1.0.5.ebuild
new file mode 100644
index 000000000000..41ebb733434a
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-1.0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"