summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-06 09:57:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-06 10:21:07 +0200
commita389562725213cfb4287e158d289feb413aba908 (patch)
tree46cb5e6943e49b0359d479e20836c2cdea74b7c8 /dev-ros/unique_id/unique_id-1.0.6.ebuild
parentdev-python/rosdistro: bump to 0.6.2 (diff)
downloadgentoo-a389562725213cfb4287e158d289feb413aba908.tar.gz
gentoo-a389562725213cfb4287e158d289feb413aba908.tar.bz2
gentoo-a389562725213cfb4287e158d289feb413aba908.zip
dev-ros/unique_id: Bump to 1.0.6.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/unique_id/unique_id-1.0.6.ebuild')
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
new file mode 100644
index 000000000000..612f302dfc98
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"