summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-15 08:20:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-15 08:20:13 +0200
commit064da91b418e64e75bdedea2a523af0fe1309fcc (patch)
tree6761c82809f70ca078ac2055cd99cdea5ee170fa /dev-ros/urdf_tutorial
parentdev-ros/urdf_tutorial: Remove old (diff)
downloadgentoo-064da91b418e64e75bdedea2a523af0fe1309fcc.tar.gz
gentoo-064da91b418e64e75bdedea2a523af0fe1309fcc.tar.bz2
gentoo-064da91b418e64e75bdedea2a523af0fe1309fcc.zip
dev-ros/urdf_tutorial: bump to 0.4.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/urdf_tutorial')
-rw-r--r--dev-ros/urdf_tutorial/Manifest1
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild25
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-ros/urdf_tutorial/Manifest b/dev-ros/urdf_tutorial/Manifest
index 4643a6c0e931..5933b5e89fde 100644
--- a/dev-ros/urdf_tutorial/Manifest
+++ b/dev-ros/urdf_tutorial/Manifest
@@ -1 +1,2 @@
DIST urdf_tutorial-0.3.0.tar.gz 871048 BLAKE2B 2bca4409696011c75e7b6c1ae811fe4caec3fe34b28ea80c9774b6068c64509a97452173c1e43ba92f77081419b58bf5f6987e1e9941eca8ce077c534636bad9 SHA512 1518cd2aa783e92dd7a996b9cff9df37f21f7585d59b6001bd9a42782b2a5d81e96e8d2502955283f29390c7fc4944250ff1d954ab6e511e0886f243c4aabbde
+DIST urdf_tutorial-0.4.0.tar.gz 865626 BLAKE2B 42a8c3274e00393f846d4e2e9641740dad214bbcdc4f65095f96f2faac1f3709170d5719085d5927ca0c322f9b8cc57b2f8494353bec629978874870a8d37206 SHA512 256859d83fb5860df27cf8922043fb61158134c1ea06f3943fed3b8183c7384819a761d83bcb03a924a813185be07e89ca510076bfa1dfe4c2e52f561503fa88
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild
new file mode 100644
index 000000000000..305da65fc713
--- /dev/null
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="URDF tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urdf
+ dev-ros/joint_state_publisher
+ dev-ros/robot_state_publisher
+ dev-ros/rviz
+ dev-ros/xacro
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslaunch[${PYTHON_USEDEP}] )
+"
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
index 5e71d2766709..305da65fc713 100644
--- a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
KEYWORDS="~amd64"
-ROS_SUBDIR="${PN}"
PYTHON_COMPAT=( python2_7 )
inherit ros-catkin