summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-10 09:08:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-10 09:51:17 +0100
commit5d7a0000a3df6f4ca578bd400d61cb60d50e31a0 (patch)
treea98ba13924ea2b3f15291aec9a23f5c571eea885 /dev-ros/urg_node/urg_node-0.1.11.ebuild
parentdev-ros/pluginlib: bump to 1.11.1 (diff)
downloadgentoo-5d7a0000a3df6f4ca578bd400d61cb60d50e31a0.tar.gz
gentoo-5d7a0000a3df6f4ca578bd400d61cb60d50e31a0.tar.bz2
gentoo-5d7a0000a3df6f4ca578bd400d61cb60d50e31a0.zip
dev-ros/urg_node: update live ebuild and bump to 0.1.11
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/urg_node/urg_node-0.1.11.ebuild')
-rw-r--r--dev-ros/urg_node/urg_node-0.1.11.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/urg_node/urg_node-0.1.11.ebuild b/dev-ros/urg_node/urg_node-0.1.11.ebuild
new file mode 100644
index 000000000000..c475a8ab1d44
--- /dev/null
+++ b/dev-ros/urg_node/urg_node-0.1.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urg_c
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/diagnostic_updater
+ dev-ros/laser_proc
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"