summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-13 11:11:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-13 11:13:05 +0200
commit40644938699c6d6c8c813040e89be07e10c60417 (patch)
tree024a3a36e51f5206a48f190478cfbfaab0b00a9c /dev-ros/urg_node/urg_node-0.1.14.ebuild
parentdev-ros/rqt_tf_tree: bump to 0.6.2 (diff)
downloadgentoo-40644938699c6d6c8c813040e89be07e10c60417.tar.gz
gentoo-40644938699c6d6c8c813040e89be07e10c60417.tar.bz2
gentoo-40644938699c6d6c8c813040e89be07e10c60417.zip
dev-ros/urg_node: bump to 0.1.14
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/urg_node/urg_node-0.1.14.ebuild')
-rw-r--r--dev-ros/urg_node/urg_node-0.1.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/urg_node/urg_node-0.1.14.ebuild b/dev-ros/urg_node/urg_node-0.1.14.ebuild
new file mode 100644
index 000000000000..cd680c30f62e
--- /dev/null
+++ b/dev-ros/urg_node/urg_node-0.1.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urg_c
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/diagnostic_updater
+ dev-ros/laser_proc
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/roslint
+ dev-ros/roslaunch
+ )
+"
+
+# https://bugs.gentoo.org/735106
+CMAKE_MAKEFILE_GENERATOR=emake