summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-05 18:14:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-05 19:55:00 +0200
commit6eb03dd80d6c042a6397f10c1631420f4e25b602 (patch)
tree65eea75ebd8f529a13bc36044f94f32c024756e4 /dev-ros/xacro/files
parentdev-ros/tf2_sensor_msgs: fix tests (diff)
downloadgentoo-6eb03dd80d6c042a6397f10c1631420f4e25b602.tar.gz
gentoo-6eb03dd80d6c042a6397f10c1631420f4e25b602.tar.bz2
gentoo-6eb03dd80d6c042a6397f10c1631420f4e25b602.zip
dev-ros/xacro: fix tests
Closes: https://bugs.gentoo.org/734694 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/xacro/files')
-rw-r--r--dev-ros/xacro/files/tests.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/xacro/files/tests.patch b/dev-ros/xacro/files/tests.patch
new file mode 100644
index 000000000000..28d4b5768c35
--- /dev/null
+++ b/dev-ros/xacro/files/tests.patch
@@ -0,0 +1,21 @@
+Index: xacro-1.14.1/test/test-cmake.sh
+===================================================================
+--- xacro-1.14.1.orig/test/test-cmake.sh
++++ xacro-1.14.1/test/test-cmake.sh
+@@ -15,6 +15,7 @@
+ test -d $1 || exit 2
+ test -r $1/CMakeLists.txt || exit 2
+
++basedir=`pwd`/../
+ dir=`basename $1`
+
+ # redirect stdout and stderr to $dir.log
+@@ -26,7 +27,7 @@ mkdir $dir
+ cd $dir
+
+ echo "*** running cmake ***"
+-cmake -DCATKIN_DEVEL_PREFIX=devel -DCMAKE_INSTALL_PREFIX=install $1 || exit $?
++cmake -DCATKIN_DEVEL_PREFIX="${basedir}/devel" -DCMAKE_INSTALL_PREFIX=install $1 || exit $?
+
+ echo
+ echo "*** running make ***"