summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-02-02 15:07:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-02-02 15:28:24 +0100
commit0a1274990889d28036b1c53130f56391bd2f6350 (patch)
tree0d9d31758f9a4e9f7a7d95d4d6652b6e6474547a /dev-ros
parentdev-ros/libmavconn: Bump to 1.5.2. (diff)
downloadgentoo-0a1274990889d28036b1c53130f56391bd2f6350.tar.gz
gentoo-0a1274990889d28036b1c53130f56391bd2f6350.tar.bz2
gentoo-0a1274990889d28036b1c53130f56391bd2f6350.zip
dev-ros/mavros: Bump to 1.5.2.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/mavros/Manifest1
-rw-r--r--dev-ros/mavros/mavros-1.5.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/mavros/Manifest b/dev-ros/mavros/Manifest
index a4cbf1623ad5..24677433e024 100644
--- a/dev-ros/mavros/Manifest
+++ b/dev-ros/mavros/Manifest
@@ -1,2 +1,3 @@
DIST mavros-1.2.0.tar.gz 309704 BLAKE2B 85fa9079e6e26a5507878a092f671dfc387f52c65b9d1b2ba1f66d98439369550807b8afe3c99e276725b0c14d479eb1df2bd75870f2b78fe6e95c6020355cc9 SHA512 b37e3713ab15bdac23e88f3e7111821c7eaaaa263d7354852a18dd1e9f6f782a2e9450b29264536b8d712ab04021ddd84d82deeb932715d8e486dc019bb6f374
DIST mavros-1.4.0.tar.gz 316881 BLAKE2B 2f7d401024fb8ce08a91e70b175bfacfcd6ec28ae8bd744ed4fba20c8a8362eaed71143c3fa34b53084d92ed5bccda3b291bc08f310f7a1c48fb25f608709c48 SHA512 d09c328d9878ada83c2c34cd44b582085e2ca5770ce78b6a52d27545333d43d5f7f92be14e3636db5ecee8d8d9e95134693ec8d4676adee5e1307ac958f182b6
+DIST mavros-1.5.2.tar.gz 319006 BLAKE2B 7ae349460f6edd44c716776dacb1014248f2d03fe0aad0a79e832091311f6e553cea714588099e70f3e1b0d8f4ba6a415e7e2554d5a8dedaae537a1955037cb4 SHA512 67aed9c6ef55c486008e1ee7125367f4ec1a6536cc7f28548c3434617a8a7429dd56a4f17af7dbe4678a8499ef69b57d72d4453fd5a2e54d9600b945314d1316
diff --git a/dev-ros/mavros/mavros-1.5.2.ebuild b/dev-ros/mavros/mavros-1.5.2.ebuild
new file mode 100644
index 000000000000..6d42a584d799
--- /dev/null
+++ b/dev-ros/mavros/mavros-1.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ sci-geosciences/GeographicLib
+ >=dev-ros/mavlink-gbp-release-2020.9.10
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"