summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 17:40:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:52:23 +0200
commit0f079a4a037aa45c7d448c3d13639d98d5371299 (patch)
tree4b1016ff330a361ada0e8b16560432f9c90bedbd /dev-ros
parentdev-ros/test_diagnostic_aggregator: fix tests (diff)
downloadgentoo-0f079a4a037aa45c7d448c3d13639d98d5371299.tar.gz
gentoo-0f079a4a037aa45c7d448c3d13639d98d5371299.tar.bz2
gentoo-0f079a4a037aa45c7d448c3d13639d98d5371299.zip
dev-ros/diagnostic_updater: fix tests
Closes: https://bugs.gentoo.org/624776 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild5
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild
index 9a772593ae84..26dc8c7e62f7 100644
--- a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild
@@ -24,3 +24,8 @@ DEPEND="${RDEPEND}
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
index 9a772593ae84..26dc8c7e62f7 100644
--- a/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
@@ -24,3 +24,8 @@ DEPEND="${RDEPEND}
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}