summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-06 18:08:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-06 18:09:03 +0200
commit10b9b3b0695c8e71312b7e6d0f72e77a016b30d0 (patch)
tree3503924155b986e33956a6dedab05ca7e9091067 /dev-ros
parentdev-ros/test_roslib_comm: fix tests (diff)
downloadgentoo-10b9b3b0695c8e71312b7e6d0f72e77a016b30d0.tar.gz
gentoo-10b9b3b0695c8e71312b7e6d0f72e77a016b30d0.tar.bz2
gentoo-10b9b3b0695c8e71312b7e6d0f72e77a016b30d0.zip
dev-ros/test_rosparam: fix tests
Closes: https://bugs.gentoo.org/625124 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.15.8.ebuild5
-rw-r--r--dev-ros/test_rosparam/test_rosparam-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.15.8.ebuild b/dev-ros/test_rosparam/test_rosparam-1.15.8.ebuild
index 16022d629a45..712bc9fd620e 100644
--- a/dev-ros/test_rosparam/test_rosparam-1.15.8.ebuild
+++ b/dev-ros/test_rosparam/test_rosparam-1.15.8.ebuild
@@ -22,3 +22,8 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
dev-ros/rosparam[${PYTHON_SINGLE_USEDEP}]
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/test_rosparam/test_rosparam-9999.ebuild b/dev-ros/test_rosparam/test_rosparam-9999.ebuild
index 16022d629a45..712bc9fd620e 100644
--- a/dev-ros/test_rosparam/test_rosparam-9999.ebuild
+++ b/dev-ros/test_rosparam/test_rosparam-9999.ebuild
@@ -22,3 +22,8 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
dev-ros/rosparam[${PYTHON_SINGLE_USEDEP}]
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}