summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-11 16:32:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-11 17:46:38 +0200
commit12a7f909cf00c6295f84626edddd89dbe437ba67 (patch)
tree27e45ffd57af8406215932a5d2bf7ab1c3403a63 /dev-ros
parentmedia-sound/rosegarden: removed obsolete unstable versions (diff)
downloadgentoo-12a7f909cf00c6295f84626edddd89dbe437ba67.tar.gz
gentoo-12a7f909cf00c6295f84626edddd89dbe437ba67.tar.bz2
gentoo-12a7f909cf00c6295f84626edddd89dbe437ba67.zip
dev-ros/ament_cmake_pytest: initial import
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_pytest/Manifest1
-rw-r--r--dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.0.0.ebuild46
-rw-r--r--dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild46
-rw-r--r--dev-ros/ament_cmake_pytest/metadata.xml11
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_pytest/Manifest b/dev-ros/ament_cmake_pytest/Manifest
new file mode 100644
index 000000000000..c2d6174e0c59
--- /dev/null
+++ b/dev-ros/ament_cmake_pytest/Manifest
@@ -0,0 +1 @@
+DIST ament_cmake-1.0.0.tar.gz 63304 BLAKE2B dd0c4bc5b72d9143cfb8ee9caae236a3608981ee8523e879ea9c168d64fd1d0cb84e54679cfc0cfc58ffff34519bb1032afc956c3130c1da8b4f98d60a9191be SHA512 69236015368df29a128eceeb64dd1c683eb32a44188b52120592238f999be8c8c7c5892a36ddcef48b6686bf97eba77e820ca3b8896c64ec1522661fa3ed4fc7
diff --git a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.0.0.ebuild b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.0.0.ebuild
new file mode 100644
index 000000000000..f0104eb06e84
--- /dev/null
+++ b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to run Python tests using pytest in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}
diff --git a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild
new file mode 100644
index 000000000000..f0104eb06e84
--- /dev/null
+++ b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to run Python tests using pytest in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}
diff --git a/dev-ros/ament_cmake_pytest/metadata.xml b/dev-ros/ament_cmake_pytest/metadata.xml
new file mode 100644
index 000000000000..d1baaf5c70f1
--- /dev/null
+++ b/dev-ros/ament_cmake_pytest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ament/ament_cmake</remote-id>
+ </upstream>
+</pkgmetadata>