summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-26 16:51:22 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-26 16:56:11 +0100
commit1a195248b834f12533b6849ac1164ac824a597bb (patch)
treed5c4bc7199eb399289bce9e71100d909178fa9be /dev-ros
parentdev-ros/ament_cmake_cppcheck: bump to 0.10.1 (diff)
downloadgentoo-1a195248b834f12533b6849ac1164ac824a597bb.tar.gz
gentoo-1a195248b834f12533b6849ac1164ac824a597bb.tar.bz2
gentoo-1a195248b834f12533b6849ac1164ac824a597bb.zip
dev-ros/ament_cpplint: bump to 0.10.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cpplint/Manifest1
-rw-r--r--dev-ros/ament_cpplint/ament_cpplint-0.10.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_cpplint/Manifest b/dev-ros/ament_cpplint/Manifest
index 2bd08ffb898e..7fd0dfc330ef 100644
--- a/dev-ros/ament_cpplint/Manifest
+++ b/dev-ros/ament_cpplint/Manifest
@@ -1 +1,2 @@
DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
+DIST ament_lint-0.10.1.tar.gz 221215 BLAKE2B 47ffa7dfd892b05f345ba962c7c08dcf1627c4653cc75e1a1d1cad28971974ef5ca9c09d3989b3fdbfacd7f94dace9651c44911cd7747f39c5c59083f0195443 SHA512 1dd996d86cfb7488bd6bf57510eb5b7531fe4fe21d25203a4801046ec719ba19afdb89eb7ba9d862317d2e041e7139fadde27d114614d96741a177e8ec2a2ba3
diff --git a/dev-ros/ament_cpplint/ament_cpplint-0.10.1.ebuild b/dev-ros/ament_cpplint/ament_cpplint-0.10.1.ebuild
new file mode 100644
index 000000000000..ad815d52a35a
--- /dev/null
+++ b/dev-ros/ament_cpplint/ament_cpplint-0.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against the Google style conventions using cpplint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest