summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 13:42:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:44:02 +0200
commit1eeb2abb5f35ed6f637ba3c34da1502da4a9c57d (patch)
tree53adc2073787452093fbc29172da774b0c1a6b8f /dev-ros
parentdev-ros/roscpp: remvoe merged patch (diff)
downloadgentoo-1eeb2abb5f35ed6f637ba3c34da1502da4a9c57d.tar.gz
gentoo-1eeb2abb5f35ed6f637ba3c34da1502da4a9c57d.tar.bz2
gentoo-1eeb2abb5f35ed6f637ba3c34da1502da4a9c57d.zip
dev-ros/roscpp: Remove old
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/roscpp/Manifest2
-rw-r--r--dev-ros/roscpp/files/boost173.patch62
-rw-r--r--dev-ros/roscpp/roscpp-1.15.7.ebuild30
-rw-r--r--dev-ros/roscpp/roscpp-1.15.8.ebuild30
4 files changed, 0 insertions, 124 deletions
diff --git a/dev-ros/roscpp/Manifest b/dev-ros/roscpp/Manifest
index e01f0dcf16ba..556c43ecfa6c 100644
--- a/dev-ros/roscpp/Manifest
+++ b/dev-ros/roscpp/Manifest
@@ -1,3 +1 @@
-DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
-DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
DIST ros_comm-1.15.9.tar.gz 1087337 BLAKE2B 8c1582425770eee7898de42785c620c5fe82e31764d8947c16f9dbb43dd03d0201344e72d5a24911f7cc3cf4eacd51d6fc2940cc2346b635a2c769b055898297 SHA512 3f009a29d74dd74169585afb8d08c41faa19128e384ef6aa6c7bf58ae4d31345e4ea5441fc99a81b7742f724df7c7e3c16c4e51473c4fddeb4b9b6bf41cff04b
diff --git a/dev-ros/roscpp/files/boost173.patch b/dev-ros/roscpp/files/boost173.patch
deleted file mode 100644
index d31f8c8ff246..000000000000
--- a/dev-ros/roscpp/files/boost173.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-Index: roscpp/include/ros/timer_manager.h
-===================================================================
---- roscpp.orig/include/ros/timer_manager.h
-+++ roscpp/include/ros/timer_manager.h
-@@ -349,7 +349,7 @@ int32_t TimerManager<T, D, E>::add(const
- {
- boost::mutex::scoped_lock lock(waiting_mutex_);
- waiting_.push_back(info->handle);
-- waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, _1, _2));
-+ waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- new_timer_ = true;
-@@ -416,7 +416,7 @@ void TimerManager<T, D, E>::schedule(con
-
- waiting_.push_back(info->handle);
- // waitingCompare requires a lock on the timers_mutex_
-- waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, _1, _2));
-+ waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- new_timer_ = true;
-@@ -490,7 +490,7 @@ void TimerManager<T, D, E>::setPeriod(in
- // In this case, let next_expected be updated only in updateNext
-
- info->period = period;
-- waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, _1, _2));
-+ waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- new_timer_ = true;
-Index: roscpp/src/libros/connection_manager.cpp
-===================================================================
---- roscpp.orig/src/libros/connection_manager.cpp
-+++ roscpp/src/libros/connection_manager.cpp
-@@ -66,7 +66,7 @@ void ConnectionManager::start()
- tcpserver_transport_ = boost::make_shared<TransportTCP>(&poll_manager_->getPollSet());
- if (!tcpserver_transport_->listen(network::getTCPROSPort(),
- MAX_TCPROS_CONN_QUEUE,
-- boost::bind(&ConnectionManager::tcprosAcceptConnection, this, _1)))
-+ boost::bind(&ConnectionManager::tcprosAcceptConnection, this, boost::placeholders::_1)))
- {
- ROS_FATAL("Listen on port [%d] failed", network::getTCPROSPort());
- ROS_BREAK();
-@@ -142,7 +142,7 @@ void ConnectionManager::addConnection(co
- boost::mutex::scoped_lock lock(connections_mutex_);
-
- connections_.insert(conn);
-- conn->addDropListener(boost::bind(&ConnectionManager::onConnectionDropped, this, _1));
-+ conn->addDropListener(boost::bind(&ConnectionManager::onConnectionDropped, this, boost::placeholders::_1));
- }
-
- void ConnectionManager::onConnectionDropped(const ConnectionPtr& conn)
-@@ -190,7 +190,7 @@ void ConnectionManager::tcprosAcceptConn
- ConnectionPtr conn(boost::make_shared<Connection>());
- addConnection(conn);
-
-- conn->initialize(transport, true, boost::bind(&ConnectionManager::onConnectionHeaderReceived, this, _1, _2));
-+ conn->initialize(transport, true, boost::bind(&ConnectionManager::onConnectionHeaderReceived, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- bool ConnectionManager::onConnectionHeaderReceived(const ConnectionPtr& conn, const Header& header)
diff --git a/dev-ros/roscpp/roscpp-1.15.7.ebuild b/dev-ros/roscpp/roscpp-1.15.7.ebuild
deleted file mode 100644
index 8863bf3d38b4..000000000000
--- a/dev-ros/roscpp/roscpp-1.15.7.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-ROS_SUBDIR=clients/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cpp_common
- dev-ros/rosconsole
- dev-ros/roscpp_serialization
- dev-ros/roscpp_traits
- dev-ros/rostime
- dev-ros/xmlrpcpp
- dev-libs/boost:=
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/boost173.patch" )
diff --git a/dev-ros/roscpp/roscpp-1.15.8.ebuild b/dev-ros/roscpp/roscpp-1.15.8.ebuild
deleted file mode 100644
index 8863bf3d38b4..000000000000
--- a/dev-ros/roscpp/roscpp-1.15.8.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-ROS_SUBDIR=clients/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cpp_common
- dev-ros/rosconsole
- dev-ros/roscpp_serialization
- dev-ros/roscpp_traits
- dev-ros/rostime
- dev-ros/xmlrpcpp
- dev-libs/boost:=
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/boost173.patch" )