summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-07-07 12:17:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-07-07 12:27:25 +0200
commit20a7488359c282f979c5a4eee42f6a1fabbd75b8 (patch)
tree9343d39063f5f886406838096c047dac5caebda6 /dev-ros
parentdev-ros/visp_camera_calibration: Bump to 0.13.1. (diff)
downloadgentoo-20a7488359c282f979c5a4eee42f6a1fabbd75b8.tar.gz
gentoo-20a7488359c282f979c5a4eee42f6a1fabbd75b8.tar.bz2
gentoo-20a7488359c282f979c5a4eee42f6a1fabbd75b8.zip
dev-ros/visp_hand2eye_calibration: Bump to 0.13.1.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/visp_hand2eye_calibration/Manifest1
-rw-r--r--dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.13.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/visp_hand2eye_calibration/Manifest b/dev-ros/visp_hand2eye_calibration/Manifest
index 577d34c98191..d29da83f02a9 100644
--- a/dev-ros/visp_hand2eye_calibration/Manifest
+++ b/dev-ros/visp_hand2eye_calibration/Manifest
@@ -1,2 +1,3 @@
DIST vision_visp-0.11.1.tar.gz 1014349 BLAKE2B 63148bef65a8361be7cb4a3d27bae4e6440feeeca3ab7183c6c345d4d1a2e0e4f7bc52b265455636ae8e07ddbed0e182c8d0b326b7686cdeda97500203fe3183 SHA512 cb1a09fea7ed2bb74c0c3f5a525d35ef7304dc2c569c6c808cd3751e500b7e32f226436ec4150f63a8280bc3f0c53dfd64757aa09da7344b1ec998130006253c
DIST vision_visp-0.12.1.tar.gz 1014707 BLAKE2B 0c482268761f75e4e36260bb8a98c32677e500f322b3807eda7e24c35681d5fee628e422b67ab9ae73c6a27b467d600ca5ba72220a09e93b146b97273b5d0d54 SHA512 9e050009a335bd8d7f3c024e460087139b43e5b4c44c2048409176b8503aa81193916e767ce06df48fa5d0f0ca23ac551df7201e92e7de65967b9f2df5a1bf7c
+DIST vision_visp-0.13.1.tar.gz 1015139 BLAKE2B 8550c32b39cb94785221d924a97795d5b865327bbb8d570131fccf91c95eaee47f242eea5826efb04b083bf467ae8400729a40cb992fe5f1e689648718958d63 SHA512 bf40f4b81a56cec1031d1d2988f6fa41b542af07b63cdd6f3994d5000f7f3e5c721580cba206918d648db5c0cfb422d06829385da94dade4b31a5e8dcf916ddb
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.13.1.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.13.1.ebuild
new file mode 100644
index 000000000000..b50f4bcfc817
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="noetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using ViSP"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_proc
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/visp_bridge
+ dev-ros/visp_tracker
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
+fi