summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 16:19:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:29:26 +0200
commit3caddeba12aac36a7f581669ef23fa3fcb6e0caa (patch)
tree6051cb6f063a4e71cf802d5f30dc238d77cedd7b /dev-ros
parentmedia-radio/xlog: Version bump (diff)
downloadgentoo-3caddeba12aac36a7f581669ef23fa3fcb6e0caa.tar.gz
gentoo-3caddeba12aac36a7f581669ef23fa3fcb6e0caa.tar.bz2
gentoo-3caddeba12aac36a7f581669ef23fa3fcb6e0caa.zip
dev-ros/joint_state_publisher: bump to 1.15.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/joint_state_publisher/Manifest1
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild22
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild6
3 files changed, 25 insertions, 4 deletions
diff --git a/dev-ros/joint_state_publisher/Manifest b/dev-ros/joint_state_publisher/Manifest
index 4114e77e44e8..951393e03d98 100644
--- a/dev-ros/joint_state_publisher/Manifest
+++ b/dev-ros/joint_state_publisher/Manifest
@@ -1,2 +1,3 @@
DIST joint_state_publisher-1.12.13.tar.gz 20658 BLAKE2B 8f0d4b1bbe5e381cb20476461a132510e0eed0cde6564557bbcf4d3c07f9036b55fb1b8ea26ef55e0085dfd2f32705d6d4d25b35c915e349c62da17e755b65c1 SHA512 012e2c4b522c9314169323066e3975d72597783a587192a176cc7f7c4b0d59a1dfd3724a57c80d6d6a628640130d235fb9fc8620f0abcd8ef81776689d05e8f1
+DIST joint_state_publisher-1.15.0.tar.gz 27974 BLAKE2B e0293f3c9496dfa47bd07e9825ed399e05b53f80947aecba228c3b153384fe5ceef808fa7a1ff5678448ef263c439bbcdae4e475bee206554f2cdff785175b1a SHA512 58387785f93195ab4b1f6a2d54f8d7765c5cd34df6a2bf5ab00caf032b5b1093fc9ec02e7217cd554cdcc37545295dff5652c295fb3ea91a549d23b83db02dbc
DIST robot_model-1.12.11.tar.gz 277822 BLAKE2B 3bdd2b931ddfd062594ccb2be4ce6d4863a5fa66f538c3ee48c3600b3be249d267f9d03aa9a701bc6ab22c4297d659a24da668fedcd25c75fe128c43cc781be0 SHA512 8dea6fc72e9beaddbf9a82cb177561cb89c69ef8f58f0c4882598f6cc33a0e10564d9696f07b6f4e3e3404d3f1f5236e54eea4b8d249be0a216cd3ce12a03cde
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild
new file mode 100644
index 000000000000..fc248b3b5af7
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.15.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
index 5f4325158a53..fc248b3b5af7 100644
--- a/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -17,7 +16,6 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/python_qt_binding[${PYTHON_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${DEPEND}